CoffeeScript, which attempts to make it easier to program in JavaScript, has a newly released beta version that features ECMAScript 2015+ support.

The currently downloadable 2.0 beta offers ES2015+ syntax, where ES2015+ is recognized as ECMAScript 2015 and later features. ECMAScript is the official specification underlying JavaScript. The upgrade breaks compatibility with certain CoffeeScript 1 features to conform with ES2015+, according to coffeescript.org’s bulletin.

“Since the CoffeeScript 2 compiler outputs ES2015+ syntax, it is your responsibility to either ensure that your target JavaScript runtime(s) support all these features, or that you pass the output through another transpiler like Babel, Rollup, or Traceur Compiler,” the bulletin says.

To read this article in full or to leave a comment, please click here